What Version Of PHP & MySQL Are Currently Running On WPX Hosting?

We currently support PHP versions starting from 7.0 up to 7.4.

Keep in mind that the PHP version 5.6 will no longer receive any security updates or bug fixes. There has been fixes and updates throughout the life cycle of PHP, and for PHP 5.6 these will stop. That is why we’ve decided to leave that PHP version in the past.

We fully support PHP 7.4 and the following:

Litespeed
PHP: 7.2 to 7.4
MariaDB:10.4

More recent versions of these have not yet proven their stability in a dynamic hosting environment to our satisfaction.MariaDB:10.4

How To Enable PHP 7.X

In your WPX Dashboard, there is a switch for the PHP version next to each website in that account. To change your PHP version, go to My Services (1) → Manage All Sites in this Account → Websites/SSL (2) and from here, select Settings (3) next to your chosen domain. You will then see the PHP tab (4) in the drop-down menu; select the PHP version (5) you prefer and select Save Changes when you’re done;

Please note that PHP 7.X might not be supported by some plugins and themes you may use. Be sure to check your that websites are working smoothly after the PHP upgrade.

If you’re unsure, check with the developers of your themes and plugins BEFORE enabling them inside your WPX admin panel.

Otherwise, you can test it by switching to PHP 7.X and reverting back to an earlier PHP version if your site stops functioning correctly.

If you get stuck with any function discussed here, please contact WPX Support via live chat (use the bottom right hand widget!) and they will usually respond and help within 30 seconds or less.