1. Home
  2. FAQ
  3. What version of PHP & MySQL is currently running on WPX?

What version of PHP & MySQL is currently running on WPX?

We currently support PHP versions starting from 7.2 up to 8.1.

PHP version 5.6 will no longer receive any security updates or bug fixes. There have been fixes and updates throughout the life cycle of PHP, and those updates will stop for PHP 5.6. The same goes for PHP versions such as 7.0-7.3 however, we may still be able to enable PHP 7.0-7.3 for your website if that is necessary.

  • Litespeed: 5.4.11 up to 6.0.11;
  • PHP: 7.2 to 8.1 (If you need PHP versions 7.0-7.3 our support agents may be able to assist you);
  • MariaDB: 10.4 up to 10.5.

More recent versions of these have not yet proven their stability in a dynamic hosting environment to our satisfaction.

It is advised to use the latest PHP version that is available because it is not only the fastest but the most secure.

Here you can check the officially updated and support versions on the PHP website: https://www.php.net/supported-versions.php

You can find a full tutorial on how you can change the PHP version of your website from the WPX control panel here.

If you have any other questions on the topic, don’t hesitate to contact the WPX Support Team via live chat (use the bottom right-hand widget) and they will respond and help within 30 seconds or less.

Was this article helpful?

Related Articles

Need Support?
Can’t find the answer you’re looking for? Don’t worry we’re here to help!
Contact Support